Instalasi Mikrotik CHR pada VPS Cloud CENTOS 7

Diterbitkan pada

Halo sobat , pada artikel kali ini saya akan mencoba untuk menulis sebuat artikel cara instalasi mikrotik chr pada vps cloud .

Sebelumnya jika sobat belum mempunyai vps cloud , sobat dapat membelinya di tempat penyedia jasa layanan vps .

Sobat bisa menggunakan vps dengan minimal ram 128mb atau rekomendasi dari saya yaitu 512mb dan 1 core cpu dengan hdd 10gb .

Langsung saja ke sedikit penjelasan mengenai Cloud Hosted Router (CHR) merupakan versi sistem operasi RouterOS dari MikroTik untuk dijalankan pada Virtual Machine (VM). Mendukung arsitektur x86 64-bit dan dapat digunakan pada berbagai hypervisor seperti VMWare, Microsoft Hyper-V, VirtualBox, Kernel-based Virtual Machine (KVM), Proxmox Virtual Environment (PVE) dan lainnya. Penulis tertarik mengujicoba Mikrotik CHR yang dijalankan pada Virtual Private Server (VPS).

Adapun langkah-langkah menginstalasi Mikrotik CHR pada VPS CENTOS adalah sebagai berikut:

  1. Remote access via SSH ke alamat IP dari VPS yang telah disewa menggunakan aplikasi Putty atau BitVise SSH Client.
  2. Menginstalasi paket wget & unzip yang nantinya digunakan untuk mengunduh file images Mikrotik CHR dari situs Mikrotik dengan mengeksekusi perintah:
    # yum -y install wget
    # yum -y install unzip
  3. Mengunduh file images Mikrotik CHR menggunakan utilitas wget, sebagai contoh versi yang diunduh adalah 6.46.4.
    # wget https://download.mikrotik.com/routeros/6.46.4/chr-6.46.4.img.zip -O chr.img.zip
    Hasil dari eksekusi perintah wget dan verifikasinya menggunakan perintah ls, terlihat seperti pada gambar berikut:

4. Mengekstrak file chr.img.zip menggunakan perintah unzip chr.img.zip dan memverifikasi hasilnya menggunakan perintah ls, seperti terlihat pada gambar berikut:

5. Melakukan mount file chr-6.46.4.img ke direktori /mnt menggunakan perintah:
# mount -o loop,offset=512 chr-6.46.4.img /mnt

6. Memverifikasi hasil mountfile images tersebut dengan mengeksekusi perintah:
# ls /mnt
Hasilnya terlihat seperti pada gambar berikut:

7. Membuat perintah Command Line Interface (CLI) untuk mengatur pengalamatan IP pada interfaceether1 dan default route serta server DNS dari Mikrotik CHR dengan menggunakan perintah echo dan menyimpan hasilnya di file autorun.scr pada direktori /mnt/rw. Perintah CLI tersebut, terlihat seperti berikut:
# ADDRESS=`ip addr show ens3 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip dns set servers=1.1.1.1,8.8.8.8" > /mnt/rw/autorun.scr
PENJELASAN : Nilai IP pada interface ether1 dan default route dari Mikrotik CHR diambil dari alamat IP dan default gateway yang digunakan oleh VPS CentOS 7. Alamat IP tersebut diperoleh dengan mengeksekusi perintah ip addr show ens3 | grep global | cut -d' ' -f 6 | head -n 1 ens3 bisa saja berbeda dengan yang sobat miliki , adapun yang menggunakan eth0 ataupun eth1 selanjutnya yaitu menyimpan hasilnya pada variableADDRESS.
Sedangkan alamat default gateway diperoleh dengan mengeksekusi perintah ip route list | grep default | cut -d' ' -f 3 dan menyimpan hasilnya pada variable GATEWAY. Nilai yang ditampung pada variableADDRESSdijadikan inputan untuk perintah /ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]. Begitu pula nilai dari variable GATEWAY juga dijadikan inputan untuk perintah /ip route add gateway=$GATEWAY.
Selain itu juga mengatur alamat server DNS dari Mikrotik CHR menggunakan Cloudflare & Google DNS yaitu 1.1.1.1 dan 8.8.8.8 menggunakan perintah /ip dns set servers=1.1.1.1,8.8.8.8.
Hasil eksekusi dari perintah tersebut pada terminal, diperlihatkan pada gambar berikut:

Sedangkan hasil verifikasi terhadap pengaturan tersebut dapat dilakukan dengan mengeksekusi perintah cat /mnt/rw/autorun.scr, seperti terlihat pada gambar berikut:

8. Melepas akses (unmount) semua partisi yang saat ini sedang terakses (mount) dengan mengeksekusi perintah:
# echo u > /proc/sysrq-trigger

9. Membuat salinan seluruh isi dari file imageschr-6.46.4.img ke /dev/vda menggunakan utilitas dd (disk dump).
# dd if=chr-6.46.4.img bs=1024 of=/dev/vda
Parameter bs digunakan untuk mengatur jumlah byte yang akan disalin pada satu waktu dimana dalam hal ini adalah 1024 byte. Hasil eksekusi dari perintah tersebut, seperti terlihat pada gambar berikut:

10. Melakukan reboot VPS melalui Client Area

11. Akses Mikrotik CHR pada VPS menggunakan Winbox. Pada parameter Connect to: dari kotak dialog aplikasi Winbox yang tampil, masukkan alamat IP Publik dari VPS yang saat ini telah digunakan oleh Mikrotik CHR. Sedangkan pada parameter Login:, masukkan “admin” dan Password: dikosongkan (tanpa sandi), seperti terlihat pada gambar berikut:

Klik tombol Connect untuk terkoneksi ke Mikrotik CHR pada VPS. Apabila koneksi berhasil dilakukan pada akan terlihat kotak dialog berikut:

Disarankan segera mengatur password login dari useradmin” untuk meningkatkan keamanan dari MikroTik CHR. Setelah itu sobat dapat melakukan konfigurasi pada fitur-fitur dari Mikrotik CHR sesuai dengan kebutuhan.

Selamat, sobat telah berhasil menginstalasi Mikrotik CHR pada VPS Centos.

Bismillah ..
More posts by Muhamad Ghufron.
Instalasi Mikrotik CHR pada VPS Cloud CENTOS 7
Share
Twitter icon Facebook icon